Kbase P84913: AdminServer is not properly started after installing 9.1D09 or 9.1E
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  20/08/2008 |
|
Status: Verified
SYMPTOM(s):
Progress Explorer does not show any folders under local host
AdminServer is not properly started after installing Progress 9.1D09 or 9.1E
Can not add Server in Progress Explorer.
NameServer does not start
WebSpeed broker does not start
Unable to find wsbroker1 (8281)
AppServer broker does not start
Unable to find asbroker1 (8281)
admserv.log shows the following error related to jni_dsm.dll
java.lang.UnsatisfiedLinkError: Can't load library: jni_dsm.dll
There is no jni_dsm.dll file in $DLC/bin
admserv.log shows the following error related to rocket.dll
java.lang.UnsatisfiedLinkError: Can't load library: rocket.dll
There is no rocket.dll file in $DLC/bin
No database license installed
AdminServer cannot be stopped with proadsv -stop cmd
FACT(s) (Environment):
All Supported Operating Systems
Progress 9.1D
Progress 9.1E
OpenEdge 10.0B
CHANGE:
Installed service pack 9.1D09 or migrated to 9.1E
CAUSE:
Bug# 20040622-002
CAUSE:
This is a known issue that was introduced in Progress 9.1D09 where the the osmetrics.dll is automatically loaded by AdminServer by default in error. Some licenses (like AppServer,WebSpeed, Soniq 4GL Adapter) do not install these jni_dsm.dll rocket.dll files, which are needed for osmetrics.dll dependency in the AdminServer introduced by fathom upgrades.
FIX:
This issue has been addressed in the following Service Packs:
Progress 9.1E01 and higher
OpenEdge 10.0B02 and higher.
If upgrading is not possible then as a workaround the Solution is to either disable the OS plugin (if NOT running Fathom Management for which the osmetrics is needed) or to copy the jni_dsm.dll file from any other installation of the same Progress version into $DLC/bin, where the license (like Database) which does install that file. These methods are described below:
1.) If not running Fathom Management, disable the OS plugin responsible for loading of osmetrics.dll for AdminServer
STEPS:
a) stop (kill) the AdminServer
b) open $DLC/AdminServerPlugins.dat and disable the following plugins:
# DatabaseAgent
# SMDatabasePlugin
# SystemPlugIn
by finding the associated lines for each and commenting them out.
For example:
# Operating System Plugin
#
#SystemPlugIn
#0
#com.progress.system.SystemPlugIn
#progress.jar
#Operating System Plugin
c) Save the $DLC/AdminServerPlugins.dat file and restart the AdminServer.
If Fathom Management is in use then:
2.) STEPS: WINDOWS
a) Copy the jni_dsm.dll and rocket.dll files from another Progress installation of the same version into %DLC%/bin
#if using FTP, don't forget to BINARY transfer
b) And then stop and start the AdminServer and connect from Progress Explorer again.
2.) STEPS: UNIX
a) Copy the jni_dsm.dll and rocket.dll files into $dlc/bin #if using FTP, don't forget to BINARY transfer
b) Change ownership and permissions on each, for example:
$ chown root:root $dlc/bin/jni_dsm.dll
$ chmod 755 $dlc/bin/jni_dsm.dll
d) And then stop and start the AdminServer and connect from Progress Explorer again.