Consultor Eletrônico



Kbase P83113: Performance degradation occurs in 9.1D09 once an OCX is loaded
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   8/24/2009
Status: Verified

SYMPTOM(s):

Progress 9.1D09

Performance drop after installing 9.1D09 service pack

Application is running slower after installing the 9.1D09 service pack

Performance degradation in 9.1D09

Using ActiveX Controls

Performance of the interface is slower in 9.1D09 once an OCX is loaded

FACT(s) (Environment):

Progress 9.1D
Windows NT 32 Intel/Windows 2000

CHANGE:

Installed 9.1D09

CAUSE:

Bug# 20040604-009

CAUSE:

A defect was introduced in 9.1D09 Service Pack for MS Windows that is specific to the use of an OCX within an application, including Dynamics applications. Any use of an OCX will cause a performance degradation in all other windows associated with that Progress application.

Using ActiveX Controls in 9.1D09 will slow down the user interface of the application. The problem will get worse for each OCX that is loaded. If you close all the windows that contain ActiveX Controls the problem will lessen, but the performance will still be slower.

FIX:

Upgrade to 9.1E, 10.0B or later release, or install the 9.1D0980 temporary fix.

To install the 9.1D0980 temporary fix:

1. Go to the Progress Electronic Software Download Site;
http://www.progress.com/am/opn/esd-login.fcc?

2. Download the Windows 9.1D0980 release (This will only be found under V9.1D Service Pack 09 Win32 Intel)

3. Run the exe and unzip the files to your DLC directory.

If you have a WebClient application and you are hosting the WebClient install image, you should also download the 9.1D0980 WebClient fix. This provides a new web_image. So run the exe provided by the download and unzip the web_image folder to your <DLC>\webinstall\webclient\web_image directory. (Note, the WebClient install image hosted on the Progress Website does not have this OCX problem.)

This 9.1D0980 WebClient download also includes bin/prowc.dll and bin/prowc.exe. If one of your WebClient customers has already upgraded to 9.1D09 you should make these files available to these customers (e.g., via an FTP site or email). Your WebClient customer would have to find where WebClient is installed on their machine and replace these two files in the bin directory. (If they don't remember where they installed WebClient, they can use the Search option in the Windows Explorer and look for bin/prowc.exe.)

NOTE: If you have previously installed any 9.1D09 temporary fix, do not install the 9.1D0980 release. Instead, please contact your regional Technical Support office.