Consultor Eletrônico



Kbase P8174: NameServer has start issues when there are missing registry keys
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   09/08/2004
Status: Unverified

FACT(s) (Environment):

Progress 9.1C

FACT(s) (Environment):

Windows 32 Intel

FACT(s) (Environment):

Windows NT 32 Intel/Windows 2000

SYMPTOM(s):

NameServer fails to start with error

Error - fail to get access to Promsgs file..(com.progress.common.util.PromsgsFile$PromsgsFileIOException: juPrmOpen: unable to open message file: promsgs.

Adminserver is started with specific userid

NameServer starts when nsman is invoked witin the PROEVN shell

NameServer starts when DLC is set at the system level

NameServer starts when DLC is not set at the system level, but set within the Unified Broker Environment variable tab

Progress installation is done by local system administrator

CAUSE:

The Userid starting the Adminserver is the same as one that logs onto the machine to invoke WebSpeed. No registry keys for DLC exist under the Userid account, however all DLC keys exist for local system administrator account.

FIX:

Start Adminserver as local Administrator account