Kbase P80947: Cannot start database through Progress Explorer - error (8619)
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  8/10/2004 |
|
Status: Unverified
FACT(s) (Environment):
Progress 9.x
SYMPTOM(s):
Cannot start database through Progress Explorer
Error 8619 when trying to re-start database from Progress Explorer
** This process terminated with exit code 1. (8619)
Database has not been started from outside the Progress Explorer
After-image Writer check box not used
Database can be started with proserve
Database still returns error 8619 after bi file is truncated
Error 8619 is almost immediate there is no delay
Always the same database that does not start out of the several databases managed by Progress Explorer
When only this database is started through Progress Explorer, it doesn't start - error 8619
Unsetting Autostart on all databases then re-starting the AdminService and starting this database, still error 8619
This database configuration has been checked
Reparing the structure of the database with prostrct repair still errors 8619 on startup
CAUSE:
Exact cause unknown.
FIX:
In this particular instance we were able to start the database through Progress Explorer by doing the following:
1.) Took a backup of the errant database:
$ probkup dbname <devicename>dbname.bak
2.) Deleted the errant database:
$ prodel dbname
2.) Created a new database structure:
$ prostrct create dbname dbname.st
3.) Restored the backup:
$ prorest dbname <devicename>dbname.bak