Consultor Eletrônico



Kbase P78319: Errors starting database via progress explorer for database on mapped drive - permissions
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   23/01/2008
Status: Verified

FACT(s) (Environment):

All Supported Operating Systems
Progress 9.x
OpenEdge 10.x

SYMPTOM(s):

Errors JUNMsg030 and JUNMsg023 when starting database using progress explorer

Cannot start the database via progress explorer utility

Error in database startup. (JUNMsg030)

Startup of database <dbname> failed - File not found (JUNMsg023)

Cannot start the database via ProControl

Receive error cannot find database file

Browsing for database via ProControl cannot see the database

Windows Explorer can see the database in the same path being used by Progress Explorer and ProControl

Database located on a mapped drive

AdminServer started as local system account

Can start the database from the command line using proserve command.

Able to create a sports2000 database in a different directory and start it via ProControl or progress explorer utilities

CAUSE:

Some users and permissions were missing from the security tab for the directory where the database was located.

FIX:

Add users and set appropriate permissions for the directory and subdirectories where the database resides.

Steps:

1. Select mapped drive and directory where database exists.
2. Right click on Properties -> Select Security Tab.
3. Add user account and then validate permissions for the account
or the users group to ensure they have read and write access.