Consultor Eletrônico



Kbase P77365: Cannot connect to database on Novell, error (777)
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   12/17/2004
Status: Unverified

FACT(s) (Environment):

Progress 7.3x
Novell Netware 4.11

SYMPTOM(s):

Unable to connect to database on Novell

PROGRESS LOG FILE: Unable to find server with protocol "tcp" in /etc/services (777)

_MPROSRV.NLM: The CPU encountered a problem executing code in _MPROSRV.NLM. The problem may be in that module or in data passed to that module by another NLM.

Unable to upgrade Clients to Progress 8.3E or apply patch 7.3C16

Cannot enable SPX protocol

CHANGE:

Changed fabric of network from SPX to TCP/IP

CAUSE:

Client32 has NOT been certified by Progress to be used with the DOS products and TCP/IP.

FIX:

** Please note: The following solution is unsupported and may prove to be unstable in the client-server architecture **

In order for 7.3X remote clients to be able to use TCP, you will need to install a 3rd party TCP/IP stack sofware, since v7.3X does not support Win9X native tcp/ip protocol. This sofware could be for example PC-TCP.

The services files need to be updated to contain records for your database servers:
sys:\etc\services on Novell server as well as c:\windows\services on WIN98 clients.

Start the database(s) on Novell as follows:
LOAD _mprosrv volume:\path_to_a_database\dbname -S <servicename> -N TLI -tcponly -autoexit

Connect from client using:
CONNECT dbname -N tcp -S <servicename> -H <hostname>
# ensure that hostname is in the client's hosts file