Consultor Eletrônico



Kbase 16771: Progress Error 733. Are You Using SPX or NETBIOS ?
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   21/08/2003
Status: Technically Reviewed

FACT(s) (Environment):

MS-Windows

FACT(s) (Environment):

MS-DOS

FACT(s) (Environment):

OS/2

SYMPTOM(s):

PROGRESS cannot establish a network connection through NETBIOS or SPX.

** Server <servername> unavailable. (733)

CAUSE:

On these platforms, the default network protocol (-N) is NETBIOS. PROGRESS error 733 is issued if PROGRESS is unsuccessful in establishing a network connection through NETBIOS or SPX.

Many PROGRESS clients on PC platforms aren't capable of establishing self-service connections to database servers. If a database connection is requested from those clients, even if you don't supply any network parameter (-N, -S or -H), PROGRESS will still attempt to establish a NETBIOS connection, as NETBIOS is the default protocol.

PROGRESS clients that can establish self-service connections are: Win32 (PROWIN32.EXE), V6 OS/2, UNIX and VMS clients. Other clients aren't capable of establishing those self-serving connections and will default to a NETBIOS connection even if a self-service connection syntax is specified (CONNECT databasename or databasefullpath is a self-serving connection syntax).

If you are getting error 733, and you either wanted to establish a TCP connection or a single-user connection, this means that you either forgot the -N or -1 parameter.

FIX:

Did you really intend to establish a NETBIOS or SPX connection ?
If not, please review your connection parameters.

If you intended to establish a TCP connection, make sure that a -N TCP
is specified in the correct place.

If you intended to establish a single-user connection, make sure that
a -1 parameter is specified in the correct place.