Consultor Eletrônico



Kbase P54510: Error (6063) when starting a Progress database.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   25/02/2010
Status: Verified

SYMPTOM(s):

Error (6063) when starting a Progress database.

Code page conversion table for <table-name> to <table-name> was not found in <file-name>. (6063)

Code page conversion table for BIG-5 to ISO8859-1 was not found in convmap.cp. (6063)

FACT(s) (Environment):

American English is set as the default, and the database is English ISO8859-1.
Progress/OpenEdge Product Family
OpenEdge Category: I18N
UNIX

CAUSE:

The exact cause is unknown at the time of this writing

FIX:

Things to check:

1. Check that there is no PROSTARTUP environment variable that could be pointing to a different/wrong startup.pf file.

2. Check that the DLC is set correctly.

3. Check that the PATH doesn't have an old/incorrect version of Progress in it. If it has a wrong DLC/bin in the path then it's probably running something that it shouldn't.

4. If on UNIX, use the "which" command to make sure you're running what you think you're running. e.g. If you run "which proserve" it will tell you the
directory where it is finding proserve.

5. Is the DLC environment variable set? If not, set it. Otherwise, when it finds and runs the 'proserve' script it will set the DLC to the directory specified at the top of the proserve script.

6. Check the $DLC/startup.pf file. This is a good giveaway of whether English was indeed installed as the default.


Things to test, start simple:

1. prodb sports sports
2. proserve sports

Does that give the same errors? If not, then it's probably the database that was restored. Was a BIG-5 database restored into an ISO8859-1 structure (or vice versa), accidentally thinking that this is the way to convert the database?