Kbase P22364: Wespeed agent get disconnected from database with error 293 refering database trigger and error 49
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  8/13/2004 |
|
Status: Unverified
SYMPTOM(s):
WebSpeed agent get disconnected from database
WebSpeed server log shows error 293
<user-program> was not found. (293)
** "tgrw/rwgin008.p" was not found. (293)
Error 293 refers to a database trigger program
Database log file shows errors 49 and 9545
SYSTEM ERROR: Memory violation. (49)
Disconnecting from database <database>, user number <usernum>. (9545)
CAUSE:
Missing information where database trigger can be found.
FIX:
There are 2 ways to resolve this problem:
1) Add or correct database trigger directory into PROPATH of the WebSpeed configuration.
This can be achieved by following the steps:
1a) Using Progress Explorer:
- Right click on WebSpeed broker and select properties
- Expand the Agent treeview
- Select General
- Modify the value of PROPATH field by adding or fixing the directory where you trigger can be found.
1b) Editing ubroker.properties file:
- look for the session pertain to the WebSpeed broker
- add or modify the value of PROPATH parameter by adding or fixing the directory
2) Add or correct -trig parameter.
This can be achieved by following the steps:
2a) Using Progress Explorer:
- Right click on WebSpeed broker and select properties
- Expand the Agent treeview
- Select General
- Add or modify the value of -trig parameter into "Agent startup parameter" field. If using a parameter file, -trig parameter can be also added or modified within the parameter file.
2b) Editing ubroker.properties file:
- look for the session pertain to the WebSpeed broker
- add or modify the value srvrStartupParam parameter by adding -trig or fixing the value. If using a parameter file, -trig parameter can be also added or modified within the parameter file.