Kbase P18353: Database fails to start with errors 9212, 9214, and 9216 on the bi file
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  3/2/2009 |
|
Status: Verified
SYMPTOM(s):
Database fails to start with errors 9212, 9214, and 9216 on the bi file
Creation date mismatch. (9214)
Control Area has a creation date of <time-stamp>. (9216)
Extent <file-name> has the wrong creation date <file-name>, (9212)
Probable backup/restore error. (605)
Buffer stack overflow
Database cannot be restarted
The file listed in the 9212 error is a bi file
FACT(s) (Environment):
All Supported Operating Systems
Progress 9.1x
OpenEdge 10.x
CAUSE:
The database fails to go through bi recovery because the .bi file referenced in the 9212 message is out of synch with information stored in the database control area.
There are various reasons why this may occur, some of these are:
- Database server machine rebooted before database is finished shutting down.
- Database files are OS copied accross network without date-preservation flags
- Database files are OS copied to the wrong directory and overwrote the bi file of an_other database with the same name
FIX:
The first and recommended next-action is to restore the last known verified backup and roll forward.
Should there be no backup to revert to, then the following actions will effectively skip crash recovery but allow access to the database so that it can then be dumped and loaded.
METHOD #1:
1. verify the database structure file <dbname>.st is valid and contains full path listings to every database file
2. run: prostrct unlock dbname dbname.st
4. Access the database: proserve dbname
5. Dump and load
METHOD #2:
1. Rename the bi file referenced in the 9212 message: rm dbname.b1
2. Add blank bi file back: prostrct unlock dbname -extents
3. Force in to the database: proutil dbname -C truncate bi -F
4. Access the database: proserve dbname
5. Dump and load