Kbase 16728: Error 5192 when a Progress Client is attempting to connect to a Server
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  29/01/2005 |
|
Status: Verified
FACT(s) (Environment):
Windows
SYMPTOM(s):
Error 5192 when Progress client attempting to connect a Server
Unable to find server <name> with protocol TCP in file SERVICES or SERVICES file not found in expected location. (5192)
CAUSE:
The progress client can not locate the services name to port mapping in the OS services file
FIX:
1) First, be sure the entry is, in fact, in the services file. If not, add it.
2) Check that the service name does not contain a / (forward slash). For example, Progress/400 will cause the 5192 error. Removing the / will correct it.
3) If it is the last entry of the services file, make sure that at least one new line exists after it. If the entry doesn't have a new line, winsock will have trouble reading it, and PROGRESS may generate error 5192. This is a Microsoft behavior, as WinSock.DLL and WSOCK32.DLL are the generic Microsoft components used to perform these lookups. This issue seems to affect both 16-bit and
32-bit PROGRESS clients. If there are already new lines following the last entry of the services file, try deleting one or more of those and retyping.