Consultor Eletrônico



Kbase P81271: Unable to start the WebClient application after initial install and launch on PC with Novell Zenwork
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   13/09/2005
Status: Unverified

FACT(s) (Environment):

Progress 9.x
OpenEdge 10.x

SYMPTOM(s):

Unable to start the WebClient application after initial install and launch

Novell ZenWorks for Desktop is installed on machine where the problem occurs

WebClient application installs and initially starts, but subsequent attempt to start fails

Depending on the Novell ZenWorks and Windows version, there will be none, or one error message

Microsoft Visual C++ Runtime Library

Runtime error!

Program ...es\Common Files\Progress Software\WebClient\prowcini.exe

The application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

CAUSE:

RPAWINET.DLL which comes with Novell ZenWorks 4.x installation prevents WebClient initializer
to connect to the deployment server and retrieve application configuration file (.prowcapc).

FIX:

Upgrade Novell ZenWorks to version 6.5 or later.

In case where the upgrade is not possible, use the following workaround:

Locate the file RPAWINET.DLL (most likely in the Windows system32 directory).
Remove that file, or rename it in something else (like RPAWINET.OLD) and then
restart the machine and re-test the WebClient application startup.