Kbase P81037: The SonicMQ Adapter fails to start with error 8297
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  9/4/2009 |
|
Status: Verified
SYMPTOM(s):
The SonicMQ Adapter fails to start with error 8297
Unable to shutdown (8279)
Unable to start sonicMQ1 (8297)
The SonicMQ Adapter will not start
Attempting to start the Adapter from adaptman tool results in error 8279
FACT(s) (Environment):
After attempting to start the Adapter through Progress Explorer, status bar displays:
"Started. Please check status."
After checking Status, status bar displays:
"Still starting, try again later"
No error messages in log files, <Adapter_Name>.broker.log or <Adapter_Name>.server.log
Admin Servers' log file displays:
[AdminServer] SvcControlCmd.connectToService() failure: Unable to connect to the service process at rmi://<AdminServer_Host>:<AdminServer_Port>/<Adapter_Name>(after 2 retries) (8171)
All Supported Operating Systems
Progress 9.1x
OpenEdge 10.0B
CAUSE:
The necessary jar files are not included in the PROGRESSCP or the jar files have not been copied into DLC/java/sonicMQ/lib
FIX:
Verify that the following has been completed:
1. The DLC/java/sonicMQ/lib directory has been created to include the necessary SonicMQ jar files.
2. The following jar files have been copied from the SonicMQ installation to the new DLC/java/sonicMQ/lib directory:
sonic_Client.jar
sonic_Selector.jar
sonic_Crypto.jar
sonic_ASPI.jar
sonic_XA.jar
sonic_XMessage.jar
activation.jar
3. Verify that the PROGRESSCP contains the jar files.
On Windows platforms the PROGRESSCP environment variable is located in the registry at:
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\PROGRESS\<version>\JAVA
On Unix systems it is located in DLC/bin/java_env.
4. If the problem was with the PROGRESSCP setting then you will need to restart the AdminServer after the above changes are performed.