Kbase P80977: Error 778 connecting Progress 9.x clients to a Progress 8.x database
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  5/18/2004 |
|
Status: Unverified
SYMPTOM(s):
Error 778 connecting Progress 9.x clients to a Progress 8.x database
Error reading socket, ret=0, errno=0. (778)
Error <read/writing> socket, ret=<n>, errno=<n>. (778)
When 778 error occurs, all users are disconnected from the database
Same configuration works properly at other sites
Database logfile contains errors 6081, 6091, 3646, 111, 2249
bkioWrite: lseek error <error number> on file <file> at <address>, file <file-name>. (6081)
<function>:Insufficient disk space during <system call>, fd <file descriptor>, len <bytes>, offset <bytes>, file <file-name>. (6091)
bkxtn: write error, file <file-name> errno: <number>. (3646)
SYSTEM ERROR: Unable to extend the database. (111)
Begin ABNORMAL shutdown code (2249)
All error messages referred to the .DB file
PROSTRCT LIST returned error 3745
<database-name> is not a multi-volume database. (3745)
DIR of database directory shows that the .DB file is 2GB
CAUSE:
.DB file of single-volume database has reached the 2GB size limit and has abnormally shutdown. This caused all users to become disconnected from the database and generated the 778 error message.
FIX:
Convert the single-volume database to a multi-volume database to overcome the limitation