Kbase P80035: Disconnecting the AppServer takes long time
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  11/05/2004 |
|
Status: Unverified
FACT(s) (Environment):
Progress 9.x
FACT(s) (Environment):
OpenEdge 10.x
SYMPTOM(s):
Disconnecting the AppServer takes long time
Using the DISCONNECT() method on the AppServer server handle.
Machine hosting the AppServer becomes unavailable after the last
executed RUN...ON statement and before calling the DISCONNECT() method.
Problem in itself is that when the machine hosting the AppServer goes down,
or becomes unavailable due to the network issues, the disconnect executed
on the client takes long time.
CAUSE:
Network latency problem.
FIX:
This is the network related issue and it can not be managed from within
the Progress 4GL. It is required to investigate the network latency problem
and address it in order to minimize the time required for the 4GL to return
after executing the AppServer disconnect.