Consultor Eletrônico



Kbase P79657: Webspeed agents hang when calling AS/400 CL program
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   5/11/2004
Status: Unverified

FACT(s) (Environment):

IBM AS/400 (RISC)

FACT(s) (Environment):

Progress/400 DataServer

SYMPTOM(s):

Webspeed agents hang when calling AS/400 CL program

When the CL program is called the agents stay in a BUSY state.

Webspeed application works as expected when not calling AS/400 CL program

Webspeed application works as expected when the full qualifying path to the AS/400 CL program is provided

The CL program being called is located via library list (*LIBL) in the Progress code

The control wasn't returned back to the Webspeed Application as the CL program couldn't be found in the library list

CAUSE:

The library list for the user was changed. The location of the CL program was removed from the *LIBL.

FIX:

Correct the library list of the user initiating the session so as it included the library where the CL program resides.

Alternatively use the full qualifying path in the application to the CL program which is to be called