Kbase P79615: Client cannot use Database. It cannot be opened. (598)
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/9/2008 |
|
Status: Verified
SYMPTOM(s):
<file-name> is a copy of <file-name>. Database cannot be opened. (598)
FACT(s) (Environment):
Windows 32 Intel
Clients is sharing Progress installation on the host via a mapped drive.
Database is on a local drive on the host.
Client is connecting in -RO mode to the database on the mapped drive.
Progress/OpenEdge Product Family
CAUSE:
Drive letter the database was created on is different then the drive letter for the Clients share.
FIX:
Create the database on a drive letter that will have the same letter designation as the clients mapped drive letter.
Example:
Host machine has a local drive that is the F: drive.
Create the database on the F drive.
Create a share on the host for the directory containing the database.
On the clients PC create a share with a drive letter of F.
Target line for Clients short cut would look something like:
R:\dlc\bin\prowin32.exe -db F:\wrk\sports -p dict.p -RO