Consultor Eletrônico



Kbase 16683: Errors 5175, 5179 and 5180 when Event Viewer is full
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   3/13/2009
Status: Verified

SYMPTOM(s):

Getting error 5175, 5179 and 5180 in the Database log file

Getting error 5180 on the client side

Registry error : Could not create the '' key for the Event Viewer. (5175)

Registry error : Could not register '' events with the Event Viewer. (5179)

Event Logger error : Could not post a '' event to the Event Viewer. (5180)

Event Logger error 997: Could not post a '' event to the Event Viewer. (5180)

FACT(s) (Environment):

Progress 8.x
Progress 9.x
OpenEdge 10.x
Windows

CAUSE:

The Event Viewer has reached its maximum size either on the server machine or on the client.

If the error was raised on a client, the error will appear in the database log file immediately followed by:

Previous message sent on behalf of user <user number>. (5512)

FIX:

Progress writes information to the database log and to the Windows Event logs (readable using the Windows Event Viewer).

The Event Viewer has options to modify how big the log can grow and what it should do if it reaches the maximum size.

The default size for the Event Viewer log is 512K. If running a database with a large amount of activity or several databases, this may not be sufficient.

Increase the size of the Event Viewer log to see if the frequency of the errors decreases or disappears completely. If the frequency decreases but the error doesn't go away then increase the size of the log file again:

1.- Go to Start > Programs > Administrative Tools > Event Viewer.
2.- Go to Log > Clear All Events, to empty the log file;

or

3.- Select Log > Log Settings, increase the maximum size of the log file;

or

4.- Select Log > Log Settings, select overwrite events as needed.