Consultor Eletrônico



Kbase P77383: Error 80 during bulkload
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   23/09/2010
Status: Verified

SYMPTOM(s):

Error 80 during bulkload

** The month of a date must be from 1 to 12. (80)

FACT(s) (Environment):

Progress 9.1x
OpenEdge 10.x
All Supported Operating Systems

CAUSE:

Data was dumped from a session with a different -d date format than the session that load is being done in.

An example with sports using 9.1D08 on Windows 2000 -

1. prodb sports sports
2. prowin32 -1 sports -d mdy
3. In the Progress session go to Tools > Data Administration, dump df, data and create the bulk loader description file (sports.fd). Checking the footer of the .d files should show that they were dumped with a date format of mdy.

4. prodel sports

5. prostrct create sports
6. procopy %DLC%\empty sports
7. prowin32 -1 sports, access the Data Administration and load the df.

8. In a proenv session the following command -

proutil sports -C bulkload sports.fd

will return the error 80 and the affected data will not be loaded. The date format used by default by the proutil utility will depend on what date format was specified when Progress was installed (dmy, in the case of this example).

FIX:

Specify the required -d format in the proutil bulkload command, e.g. for the example above -

proutil sports -d mdy -C bulkload sports.fd

The format can be found in the footer to the .d file, e.g. dateformat=mdy-1950.

Note that before carrying out the bulkload again with the correct -d, the database should be recreated completely (steps 5-7 above). Otherwise there is the possibility that duplicate records will be created, since the bulkload utility deactivates indexes.