Consultor Eletrônico



Kbase P76435: Crystal Reports Runtime LogOnServer method fails with error "Logon Failed" (5890)
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   12/14/2006
Status: Verified

FACT(s) (Environment):

Progress 9.1D
Progress 9.1E
OpenEdge 10.0x
Crystal Reports 9
Crystal Reports 10
Crystal Reports 11 (XI)
Windows

SYMPTOM(s):

Using Crystal Reports Viewer Control to display a Crystal report

Code fails at the LogOnServer method with error "Logon Failed" (5890)

Error occurred while accessing component property/method: LogOnServer.
Logon failed.
Error code: 0x80020009 USER-INTERFACE-TRIGGER <Path>. (5890)

Login failed.
Details: HY000:[DataDirect-Technologies][ODBC PROGRESS Driver]Insufficient information to connect to the datasource.

Error 'Insufficient information to connect to the datasource' can be found in the ODBC Trace Log

Crystal LogOnServer method is required to establish an ODBC connection for the report

Using the following syntax for the LogOnServer method:

chApplication:LogOnServer ("crdb_odbc.dll", "<ODBC DSN Name>", "", "<Username>", "").

CAUSE:

No password is specified for the connection. If the Password parameter is left blank then no password is sent to the database. It is not possible to connect via Crystal without specifying a password even if the ODBC 'Test Connect' succeeds without one.

FIX:

Option #1
Set the Password to a space character so that it is not blank. Configure the LogOnServer method as follows:
chApplication:LogOnServer ("crdb_odbc.dll", "<ODBC DSN Name>", "", "<Username>", " ").

Option #2
Create a new user in the database and use the Username and Password to establish the connection. Configure the LogOnServer method as follows:
chApplication:LogOnServer ("crdb_odbc.dll", "<ODBC DSN Name>", "", "<Username>", "<Password>").