Kbase P75715: ODBC DSN test connect fails with message: v9.1C ODBC driver could not be loaded due to system error
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  1/6/2009 |
|
Status: Verified
SYMPTOM(s):
ODBC DSN errors with the setup routines for the MERANT 3.60 32-BIT Progress SQL-92 V9.1C ODBC driver
System error 126 is ERROR_MOD_NOT_FOUND - The specified module cannot be found
9.1D08
FACT(s) (Environment):
Windows
Progress 9.1D
CHANGE:
Failed un-install of 9.1D, followed by a re-install of 9.1D.
CAUSE:
Improper uninstall left behind a registry entry for the MERANT SQL-92 ODBC Driver. The entry is pointing to an old DLC\bin directory.
FIX:
Edit the following registry key: HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\MERANT 3.60 32-BIT Progress SQL-92 V9.1x
1. Delete any entry that references the Progress SQL-92 driver
2. Uninstall the current install
3. Manually verify the complete removal of Progress
4. Reboot the server
5. Reinstall Progress 9.1D
6. Apply 9.1D08
7. Configure the DSN
A failed uninstall may have other problems, thus the uninstall and reinstall is the best direction.
Alternatively, you could edit the Driver and Setup value data portions of the registry key to point to the correct location of the PGPRO915.DLL and the PGPRO915S.DLL files:
<InStallDir>\bin