Consultor Eletrônico



Kbase P75535: Error 11724 occurs when trying to invoke the Progress Debugger in OpenEdge 10
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   3/27/2007
Status: Verified

FACT(s) (Environment):

OpenEdge 10.0X

SYMPTOM(s):

Getting error 11724 when trying to invoke the Progress Debugger

The Progress 4GL is not enabled for debugging. Use the proDebugEnable
tool to enable debugging and set debugger Enabled to 1 for Appservers.
(11724)

Cannot STEP INTO '<procedure>'. SERVER '<server>' is not debug enabled. (5525)

Trying to use the Progress Debugger for the first time

CAUSE:

Starting in 10.0A, debugging is disabled by default

FIX:

To enable debugging on Windows:

1. Close any Progress session that you want to debug as the enabled setting is picked up when Progress starts up.
2. Make sure you are logged in as an administrator of the machine or as the user that installed the software.
3. Choose Proenv from the OpenEdge program group on the Start menu.
4. Run:

proDebugEnable -enable-all

Progress Debugger will be enabled when you start a new progress session

To enable debugging on UNIX:

1. Close any Progress session that you want to debug as the enabled setting is picked up when Progress starts up.
2. Make sure you are logged in as root.
3. Run the following from the command line:

<OpenEdge install dir>/bin/proDebugEnable -enable-all

Progress Debugger will be enabled when you start a new progress session