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Kbase P74467: Windows 32-bit Install: Cannot open registry key HKEY_LOCAL_MACHINE\SOFTWARE\Secure errno 2
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   02/02/2011
Status: Verified

SYMPTOM(s):

During installation error message Cannot open registry key HKEY_LOCAL_MACHINE\SOFTWARE\Secure errno 2.

Cannot open registry key HKEY_LOCAL_MACHINE\SOFTWARE\Secure errno 2.

Installation of OpenEdge proceeds after acknowledging the message

FACT(s) (Environment):

OpenEdge 10.x
Windows 32-bit

CAUSE:

Sometimes registry key HKEY_LOCAL_MACHINE\SOFTWARE\Secure is not created during installation. The specific reasons underwhich this occurs are unknown. One known cause is if anti-virus software is running when the installation was done, then some registry entries are not created.

This is an installation tailoring error, originating from a tailoring dll when attempting to create this Secure\ProDbgCK key in a disabled mode. When "prodebug enable" is run at some later stage, this edits this key on that machine and makes it enabled. Other parts of the product look at this key value to see if attaching a debugger is allowed.

FIX:

Create that key manually or export from a working machine and import it after modifying the path entries.

Example:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Secure]

[HKEY_LOCAL_MACHINE\SOFTWARE\Secure\ProDbgCK]
"D:\\101B\\DLC.state"="Debugging disabled"

Where the install path for Progress is D:\101B\DLC in this case.

For Windows 64-bit Servers, please refer to Solution P180787, "Windows 64-bit Install: Cannot open registry key HKEY_LOCAL_MACHINE\SOFTWARE\Secure errno 2"