Consultor Eletrônico



Kbase P74125: Can not connect to a Progress database when using ODBC connection
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   02/11/2004
Status: Verified

FACT(s) (Environment):

Windows
Progress 8.3x

SYMPTOM(s):

Can not connect to progress database via a 3rd party client

Using ODBC connection, SQL 89 driver

The oibrkr32.exe process is not running on the Task Manager

DLC, PATH, PROOIBRK, PROOIDR variables are set

oibrkr32.exe process was restarted via a .bat process

No errors occur when starting oibrkr32.exe via .bat process

Error 785 occurs when starting manually oibrkr32.exe via the command line

port is already in use (785)

CAUSE:

The problem is that when the oibrkr32.exe process is started through a batch process (.bat file), the errors are not seen. Thus one would assume that the broker process has started up just fine. However, this is not the case. By starting the broker via the command prompt, we are able to see more of the problem by the error presented.

The problem is that the broker port being referenced (at startup) is already being used or is in use on the system. This is why the third party client can not connect, thus the broker has not been started.

FIX:

Start the broker on a different port or release the port that the oibrkr32.exe is using.

To release the port, either restart the OS so that the operating system can release the port or obtain a freeware application that can release the ports on the OS.