Kbase P73747: AppServer fails to write to a mapped drive letter when AdminServer is started as a Service on Window
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  01/07/2004 |
|
Status: Unverified
FACT(s) (Environment):
Windows XP
FACT(s) (Environment):
OpenEdge 10.x
FACT(s) (Environment):
Windows 2003
FACT(s) (Environment):
Progress 9.x
SYMPTOM(s):
Write to a mapped drive, from code running on an AppServer fails.
** Unable to open file: <file-name>. Errno=2. (98)
AppServer cannot write to a mapped drive.
AppServer can write to a UNC path.
AdminServer starts as a Windows Service.
Starting the AdminServer from the proadsv command resolves the problem.
CHANGE:
Upgraded AppServer system to Windows 2003
CAUSE:
Drives mapped in an interactive logon session are not global to the system due to a change in Windows XP and 2003 architecture. Each logon session to the system receives its own set of drive letters, redirected drives cannot be shared between processes that are running under different user accounts.
A service runs in its own logon session and cannot access the drive letters that are established in a different logon session.
FIX:
Microsoft does not support the use of mapped drives.
To perform a write function from an Appserver to a network share:
1) Start the AdminServer using the proadsv command.
or
2) Change the program to use UNC naming conventions to perform the write.
to write to). Of course, this user must have appropriate
permissions.