Kbase P4272: S/E 290 with I/O error 0
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  15/10/2008 |
|
Status: Verified
SYMPTOM(s):
SYSTEM ERROR: I/O error <n> in <program>, ret <n>, file <n>,addr<n>.(290)
SYSTEM ERROR: I/O error 0 in readit, ret 1, file 0 TTY , addr 0. (290)
CAUSE:
Possible causes of this error include (but not limited to):
1) if the program indicated in the error message is a read function
(ex: readit, readfrmb, etc.) the problem may be corrupt .r files.
2) the error may be due to insufficient disk space.
3) trying to read a zero length file.
4) Progress bug if duplicated.
5) On Novell, this error will occur when the .db and/or .bi files
have no file owner. This can occur if the user who owned the db
is deleted.
6) We have run out of space or hit a file size limit or ulimit"
7) The UNIX error 0 indicates that we have reached EOF (end of file).
This can occur when we run out of space on the file system, or run into a ulimit or maximum file size limit.
FIX:
Correct problem according to the cause:
1) If corrupt .r file replace it.
2) Make sure there is sufficient disk space.
3) Avoid to access a zero length file.
4) Upgrade to the latest Progress release .
5) On Novell make sure the .db and/or .bi files have a file owner.
6) Assign the open file limit or ulimit appropriate.
7) For the database structure (.st) take care that the size of database files
cannot hit the operating system files size limit.