Kbase P40332: Error 1432 when trying to connect to the Database as a remote user using -S portnumber
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  05/08/2010 |
|
Status: Verified
SYMPTOM(s):
Error 1432 when trying to connect to the Database as a remote user using -H -S and -N
** Could not connect to server for database <DATABASE>, errno 0. (1432)
** Could not connect to server for database <DATABASE>, errno <ERRNO>. (1432)
The port <n> is already in use. (785)
hostname in the -H connection parameter results in error 1432
IP address in the -H connection parameter still results in error 1432
service number in the -S connection parameter results in error 1432
FACT(s) (Environment):
Same port number being used to connect as was used to proserve database
service name in the -S connection parameter results in successful connection
Database Server is up and running
telnet {hostname} {service} successful
telnet {hostname} {port#} successful
telnet {serverip} {port#} successful
Server services file maps {servicename} to {port#} correctly
Blank line (CR) after the last entry in the services file
Database license is installed
Windows
Progress 9.1D
CAUSE:
BUG# 20030904-003
CAUSE:
Byte-swap problem on INTEL platforms when using a portnumber that has a "byte-swapped-pair" entry in the services file.
For example, it is the presence of an entry for port 21791 (551f in hex) in the services file, while the database is started with port 8021 and the client connects with -S 8021 (1f55 in hex, byte-swapped 21791 | 551f)
FIX:
Upgrade to Progress 9.1D08 or higher.
If upgrade is not a feasible option, choose one of the following:
a) use the port NAME instead of the port number to connect to the database
b) comment out the entry of the byte-swap pair from the services file