Consultor Eletrônico



Kbase P11824: Error: socket closed. (8551) when starting an AppServer broker
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   23/02/2010
Status: Verified

SYMPTOM(s):

An error occurred while receiving a message from the NameServer - Error: socket closed. (8551)

An error occurred while receiving a message from the NameServer - Error: <host>/<IP-address>. (8551)

An error occurred while receiving a message from the NameServer - Error: <Error>. (8551)

Server has been running 4 months without reboot

FACT(s) (Environment):

Progress 9.1X
Windows NT 32 Intel/Windows 2000

CAUSE:

The exact cause is unknown at the time of this writing

FIX:

Following 2 steps have fixed the issue:
- increase registration entry for particular broker from 30 to 120
- MaxUserPort in TCP/IP registry were increased to maximum as per MS KB Q196271