Consultor Eletrônico



Kbase P71935: NameServer shuts down with errors 9362, 9411 and 9412 in the log file
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/12/2008
Status: Verified

SYMPTOM(s):

NameServer shuts down with errors 9362, 9411 and 9412 in the log file

Name Server at Host <Host> Port <Port> is not responsive. (8239)

An error occurred while listening for network input requests on port <port>. (9362)

An exception occured. Error message: <Error>. (9411)

An exception occured. Error message: Connection reset by peer: Datagram peek failed. (9411)

Multiple I/O exception errors on port <port>, the NameServer is shutting down. (9412)

Response sent to <Host> <Port>. (8202)

FACT(s) (Environment):

Progress 9.1D
Windows NT 32 Intel/Windows 2000
Windows 2003

CAUSE:

The Java 1.3.0 shipped with the Progress 9.1D causes the exception when the NameServer tries to send the UDP message on the port where no processes are listening to. This exception is intercepted by the NameServer causing its shutdown.

FIX:

1. Download and install Java 1.3.0_05 from:
http://java.sun.com/products/archive/j2se/1.3.0_05/index.html

2. Stop the AdminServer

3. Once the Java 1.3.0_05 has been installed, it is required to make following changes in order that Progress uses this version of java instead of
the one that comes with Progress installation:

a. Make the backup of the registry entries starting from:
HKEY_LOCAL_MACHINE\Software\PSC\PROGRESS\<version>\JAVA

b. Change the following registry key values:
JDKCP -> <path_to_1.3.0_05>\lib\tools.jar
JDKHOME -> <path_to_1.3.0_05>
JRECP -> <path_to_1.3.0_05>\jre\lib\rt.jar;<path_to_1.3.0_05>\jre\lib\i18n.jar
JREHOME -> <path_to_1.3.0_05>\jre

4. Restart the Progress AdminServer

For Windows2003 install Java 1.3.1_11 or latest patch for 1.3.1.