Consultor Eletrônico



Kbase P71749: Getting expection Unknown client id when stopping the AdminServer
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   3/30/2004
Status: Unverified

FACT(s) (Environment):

Progress 9.1C

FACT(s) (Environment):

Progress 9.1D

FACT(s) (Environment):

Fathom for Management 2.1A

SYMPTOM(s):

Exception at Tue Mar 09 23:02:58 GMT+01:00 2004:
java.lang.NullPointerException
Message (throw): Unknown client id. Could not send message: null
Message (excp): null
Stack Trace: java.lang.NullPointerException
at com.progress.agent.database.AgentDatabase.getIdValue(AgentDatabase.java:91)
at com.progress.agent.database.AgentDatabase.sendPacket(AgentDatabase.java:895)
at com.progress.agent.database.AgentPlugIn.shutdown(AgentPlugIn.java:324)
at com.progress.chimera.adminserver.AdminServer.shutdownPlugin(AdminServer.java:1424)
at com.progress.chimera.adminserver.AdminServer.shutdownPlugins(AdminServer.java:1378)
at com.progress.chimera.adminserver.AdminServer.doShutdown(AdminServer.java:1313)
at com.progress.chimera.adminserver.AdminServer.run(AdminServer.java:1271)
at java.lang.Thread.run(Unknown Source)

Shutting down plugin DatabaseAgent. (7436)

Exceptions when stopping the AdminServer

AdminServer throws an exception during shutdown - Unknown client id. Could not send message: null

CHANGE:

Installed 2.1A01 - Service pack 1 for Fathom 2.1A

CAUSE:

This is a known issue

FIX:

The exceptions are harmless and can be ignored.
They occur only at AdminServer shutdown for database agents that are not running.

In order to get this issue fixed:

1) please download following file
ftp://ftp.progress.com/pub/customer/outgoing/techsupport/P71749/fathom.jar

2) shutdown the AdminServer
3) place newly downloaded fathom.jar into $FATHOM/jars (backup the previous one)
4) start the AdminServer again

When next time AdminServer gets stopped there will be no further exception(s) from dbagent.