Kbase P71347: Error "Server did not respond" when connecting to a Progress 9.1x database using DataDirect 4.2 ODBC
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/27/2004 |
|
Status: Verified
FACT(s) (Environment):
Progress 9.1x
OpenEdge 10.0A
DataDirect 4.20 32-Bit OpenEdge SQL92 10.0A
SYMPTOM(s):
ODBC Test Connect fails
[DataDirect][ODBC OPENEDGE driver][OPENEDGE]Server did not respond
Database is started in multiuser mode
Error 1280 found in database logfile
Connection timed out on socket=<n> for usernum <n>, attempt disconnect. (1280)
Connection timed out on socket=48 for usernum <n>, attempt disconnect. (1280)
Connection is successful using the MERANT 3.6 ODBC driver
Connection is successful using the DataDirect 4.1 ODBC driver
CAUSE:
This is the expected behavior. The OpenEdge 10 ODBC driver (release 4.2) is not supported with a Progress 9.1x SQL-92 server. The same applies to the OpenEdge 10 JDBC driver.
FIX:
When connecting to a Progress 9.1x database via ODBC, use one of the following drivers:
MERANT 3.60 32-BIT Progress SQL-92
DataDirect 4.1 32-Bit Progress SQL92