Kbase P70237: Users accessing Progress via a Citrix server cannot not get back in after an idle timeout disconnect
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  1/2/2009 |
|
Status: Verified
SYMPTOM(s):
Users accessing Progress via a Citrix server cannot not get back in after an idle timeout disconnect.
The Citrix box is set in reset mode.
On attempted access after the idle disconnect users get widget errors and fail.
Error occurred while creating CONTROL-FRAME: <FRAME name><COM message>Error code: (5898)
Error occurred while creating CONTROL-FRAME: ActiveBar,
Error Performing inpage operation.Error code; 0x800703e7 (5898)
**Unable to realize CONTROL-FRAME widget. (4025)
Unknown error code 1 for attribute NAME on the CONTROL-FRAME widget (4104)
Unable to set attribute NAME in a widget of type CONTROL-FRAME. (3183)
Each Citrix server has a full install of Progress Client Networking.
FACT(s) (Environment):
IBM AIX
Progress 9.1D
OpenEdge Category: Database
CAUSE:
All Citrix clients have a common working/home directory.
FIX:
Change the configuration of the client connections so that each client has its own working directory.
Create separate files for users on Citrix Server machine in C:\TEMP and change -T on client connection parameter to point to C:\TEMP\%USERNAME%.