Kbase P68293: Cannot start adminserver with Fathom for Management
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  2/19/2004 |
|
Status: Unverified
FACT(s) (Environment):
Progress 9.1C
FACT(s) (Environment):
Fathom Management 2.x
SYMPTOM(s):
Cannot start adminserver with Fathom for Management
Last message on the admserv.log file:
[1/2/04 9:23:16 AM] [3] [Fathom] The Fathom OSMetrics library
loaded.
Exception at Fri Jan 02 09:33:33 EST 2004: java.rmi.NotBoundException
Message (excp): null
Stack Trace:
java.rmi.NotBoundException
at
com.progress.common.rmiregistry.RegistryManager.lookupX(RegistryManager.java:368
)
at
com.progress.common.rmiregistry.RegistryManager.lookup(RegistryManager.java:346)
at
com.progress.common.rmiregistry.RegistryManager.lookup(RegistryManager.java:339)
at com.progress.chimera.clu.dbMan.dbMan.getJuniperPlugin(dbMan.java:677)
at com.progress.chimera.clu.dbMan.dbMan.<init>(dbMan.java:128)
at com.progress.chimera.clu.dbMan.dbMan.main(dbMan.java:72)
CAUSE:
One bad CPU on the machine was causing osmetrics.dll to not being able to pull monitoring data from that CPU.
FIX:
Fix the bad CPU on the machine; To avoid the Adminserver startup problem, defensive code was introduced on Progress 9.1D08 and Fathom 2.1A