Kbase P65022: Error 9450 in the database log file
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  26/08/2009 |
|
Status: Verified
SYMPTOM(s):
Error 9450 in the database log file.
<function>:Insufficient disk space during <system call>, fd <file descriptor>, len <bytes>, offset <bytes>, file <file-name>. (9450)
FACT(s) (Environment):
All Supported Operating Systems
Progress 9.1C
Progress 9.1D
OpenEdge 10.x
OpenEdge Category: Database
CAUSE:
Error 9450 occurs when a disk operation has returned one of the following OS errors:
0 OS unsure of the problem
ENOSPC No space left on device
E_DISKFULL No space left on device
ENMFILE No more files
It is easy to notice that, despite the "Insufficient disk space" in the error message itself, running out of disk space is not the only cause for error 9450.
<function> is the name of the C function with Progress where the OS error occurred. When <function> is bkioRead, the problem occurred during a read operation; when <function> is bkioWrite, the problem occurred during a write operation.
<file-name> indicates the file where the problem occurred.
Error 9450 alone does not indicate data corruption.
FIX:
Investigate whether you are running out of disk space; <file-name> in error 9450 indicates which file generates the problem.
If the file mentioned is a database, before-image or after-image extent, you can move it to another disk (please see solution P6447 for further details).
If the file mentioned is one of the client temporary files (DBIxxxxxx, PGExxxxxx, SRTxxxxxx etc), you can relocate them (please see solutioin P6773 for further details).
If disk space is not the issue, error 9450 indicates a (possibly intermittent) hardware problem, running out of kernel resources, or exceeding the file size quota for your operating system. Please contact your hardware and OS vendors to know which utilities you can run in order to uncover the problem.