Kbase P10089: Client cannot access certain procedures in database (1422) (1124) (4229) (762)
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  11/3/2008 |
|
Status: Verified
SYMPTOM(s):
Client cannot access database (1422) (1124) (4229) (762)
SYSTEM ERROR: Index in for recid could not be deleted. (1422)
SYSTEM ERROR: wrong dbkey in block. Found <dbkey>, should be <dbkey2> (1124)
Corrupt block detected when reading from database. (4229)
SYSTEM ERROR: bkaddr called with negative blkaddr: <number> (762)
Restored database from last backup yields same results
System re-boot did not resolve the issue
Memory diagnostics have been investigated on the system
Errors appear when client accesses a procedure
FACT(s) (Environment):
All Supported Operating Systems
Progress/OpenEdge Product Family
CAUSE:
The 1124 error implies that data has been lost, other errors point to data and index corruption, 4229, for example is usually related to a hardware problem on the server.
FIX:
If reverting to a prior backup is no longer an option, a database dump and load will resolve this issue, but before doing anything, please ensure there is a valid database backup.
If you dump your database, (Data Dictionary), Progress will FAIL on corrupt data records and give the relevant error message (as already being received), this will in turn indicate each table that is corrupt, for further investigation. Please refer to Progress Solution P26318 "How to dump around corrupted records" Continue the dump process and finally reload all the files that could be recovered into a new database, then run a full idxbuild, followed by a recompile of the entire application.