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Kbase P64518: Progress 9.1D UNIX client fails to connect to the AppServer, error (8127) in AppServer broker log.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/16/2008
Status: Unverified

FACT(s) (Environment):

UNIX
9.1x

SYMPTOM(s):

Progress client fails to connect to the AppServer.

NameServer and AppServer are running.

AppServer is registered with the NameServer.

No errors are written in AppServer server or NameServer log files.

Broker is registered with NameServer

Got a connection:: (8125)

Started client thread C-0001 ... (8075)

Client connected : . (8533)

142.148.42.39::CPSCOMAS::3011::20abccecb5516805:76925182:f9ecc302b1:-7ffb. (8096)

ServerSocketsIPC localhost IOException : {1} : {2} (8127)

ServerIPCException in processConnect() : ServerIPC error. (8119)

Unhandled exception caught in S-0001. (8419)

at com.progress.ubroker.broker.ubASserverThread.processConnect(ubASserverThread.java:585)


java.lang.NullPointerException

Ending serverPool thread: S-0001. (8077)

Client disconnected : . (8534)

Error Unspecified Error ... disconnecting client. (8091)

CAUSE:

The reference to "localhost" in the error message below is the clue.

ServerSocketsIPC localhost IOException : {1} : {2} (8127)

This error is written when Progress tries to open a socket on "localhost", but can not. Progress receives an error from the operating system telling it that "localhost" is an unknown host name.

FIX:

The reference to "localhost" may have been removed from this machine's configuration. Make sure the UNIX host can resolve the reference to "localhost" back to itself. Add the following entry to the /etc/hosts file:

127.0.0.1 localhost # local loopback