Consultor Eletrônico



Kbase P64134: Cannot connect to Oracle after installation of Service Pack
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   23/01/2004
Status: Unverified

FACT(s) (Environment):

Progress 9.1D

FACT(s) (Environment):

OpenEdge 10.0A

SYMPTOM(s):

This version of PROGRESS does not support an ORACLE DataServer (5152)

Cannot connect to Oracle after installation of Service Pack

Connection to Oracle does not work anymore after installating a Service Pack

%DLC%/progress.cfg contains only 1 entry having serial number 000015001

CHANGE:

Installed Service Pack

CAUSE:

Service Pack has been installed incorrectly and Progress core installation gets corrupted.

Prior to the introduction of Service Packs, users have grown used to applying patches directly to their installed directory, this is why the change to the Win32 Intel default unzip directory was actioned.

Progress has never recommended that a patch be applied directly to the user's Progress install, but rather unzip or untar'd to a temporary working directory and then copy files to the install directory after creating a back up.

FIX:

Service Packs are installed using an Installation Utility similar to the commercial product Installation Utility.

If you have extracted the Service Pack directly into the %DLC% then you will have overwritten core 9.1D/10.0A files, therefore you will need to reinstall 9.1D/10.0A,

When you have downloaded the 9.1D Service Pack, extract the archive into a temporary directory and run the Setup.exe contained in this temporary directory. This is detailed in the "ReadmeSP.txt" file which is extracted from the archive.