Consultor Eletrônico



Kbase P64014: Error 8089 can occur when maxSrvrInstance is less than licensed user count
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   22/04/2004
Status: Unverified

SYMPTOM(s):

WebSpeed

Error 8089 in Webspeed broker log

ERROR: No servers available. (8089)

No more available agents

maxSrvrInstance value specificed is less than licensed user count.
Example; maxSrvrInstance = 10 and License count = 25

System has more licensed users available

CAUSE:

You are recieving more requests than you can handle at the current time.

FIX:

You need more available agents to handle the requests. Increase the maximum number of servers (maxSrvrInstance) if you have the available licensed users.

In Progress Explorer:
- right click on the broker
- select properties
- expand the Agent and select Pool Range
- change the value of Maximum Agents

In ubroker.properties file
- edit %DLC%\properties\ubroker.properties file
- under broker (child) component
- either set or increase the value for maxSrvrInstance

[UBroker.WS.wsbroker1]
maxSrvrInstance=25 (or to whatever number)