Consultor Eletrônico



Kbase P61920: Error 8245 when trying to connect to AppServer/WebSpeed with
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   1/9/2004
Status: Verified

FACT(s) (Environment):

Progress 9.x

FACT(s) (Environment):

WebSpeed 3.x

SYMPTOM(s):

Error 8245 when trying to connect to the AppServer

Error 8245 when trying to connect to the WebSpeed

Application Service <Application Service> not found at NameServer at Host <Host> Port <Port>. (8245)

AppServer and WebSpeed brokers are running

NameSever is running

NameServer query does not show the AppServer and/or WebSpeed broker registered to it

All components were restarted and still getting error 8245

CHANGE:

ubroker.properties file was recently manually edited

CAUSE:

The exact cause is unknown at the time of this writing.

FIX:

Revert back to the ubroker.properties.template file.

1. Stop all Progress processes. e.g. AdminServer, brokers etc.
2. Rename the current $DLC/properties/ubroker.properties file.
3. Copy the $DLC/properties/ubroker.properties.template to $DLC/properties/ubroker.properties
4. Start the AdminService.
5. Once the AdminService has started, check to see whether the NameServer has autostarted.
nsman -name NS1 -query

6. Start the asbroker1 AppServer/WebSpeed broker.
asbman -name asbroker1 -start
wtbman -name wsbroker1 -start

7. Once the AppServer/WebSpeed broker(s) have fully started, check that the broker(s) is registered to the NameServer.
nsman -name NS1 -query

**Don't forget to add your own components within this new ubroker.properties file.