Consultor Eletrônico



Kbase P684: Long Printer Name cause "Error: Specified printer is not installed" in Progress 8.3B and ealier
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   15/10/2008
Status: Verified

FACT(s) (Environment):

Progress 8.2x
Progress 8.1x
Progress 8.0x
Progress 8.3A
Progress 8.3B

SYMPTOM(s):

Report fails to print.

Error: Specified printer is not installed or specified port is not available.

Report Builder

Long printer names

CAUSE:

Bug# 19991215-036

CAUSE:

The field formats for RB-PRINTER-NAME & RB-PRINTER-PORT are too small. This causes the error because the default format for the fields in the RBREPORT table is "x(32)". ESQL doesn't have the capability of the Progress database to store both display and storage format for fields. Consequently, when Report Builder tries to access values from the Progress database, it reads values in their display format.

When you use Table Interface of the Report Engine and store long printer names/port references in the RB-PRINTER-NAME or RB-REPORT-NAME fields, Report Builder sees only the first 32 characters of the printer/port name.

FIX:

1. Upgrade to Progress 8.3C or higher.

Or

2. Change the format of these fields in the rbreport.df file or in the rbreport table to accomadate the size of the printer names.