Consultor Eletrônico



Kbase P60612: Error (44) when trying to access the database after copying files from a different machine.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   25/02/2010
Status: Verified

SYMPTOM(s):

Error (44) when trying to access the database after copying files from a different location.

** Database has the wrong version number. (db: <8192>, pro: <8275>). (44)

** Database has the wrong version number. (db: <value>, pro: <value>). (44)

Progress version being used is exactly the same at both locations.

FACT(s) (Environment):

Progress 8.x
Progress 9.x
All Supported Operating Systems

CAUSE:

During the backup / copying of the files, the files have become corrupt.

A obvious giveaway of this is that the db: <value> does not equate to a valid Progress version number.

For example, if you deduct the database block size from the version value it should equate to the Progress version being used. In the above example the database has an 8192 byte (8kb) block size and the db version says 8192, so 8192 - 8192 = 0 which is incorrect. And the client version says 8275, so 8275 - 8192 = 83, which equates to Progress version 8.3 and is correct.

FIX:

Correct the cause of the failed copy/backup and try again.