Consultor Eletrônico



Kbase P58932: Self service Progress clients/webspeed agents leaking memory with many connect/disconnect to databas
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   17/09/2008
Status: Verified

SYMPTOM(s):

Webspeed agents are growing larger in size during the course of a day

Error 1720 generated when eventually the webspeed agents are very large

Unable to attach shared memory <shmname>, errno 0 (1720)

The same problem can be caused by regular self service progress clients connecting and disconnecting the database many times

The agent session was retaining the handles to the database

The agent session was not releasing handles to the database

The handles value was up in the thousands seen from Process explorer

Most of the handles opened and not closed are for semaphores.

Problem not seen when connection is client server

FACT(s) (Environment):

Windows NT 32 Intel/Windows 2000
WebSpeed 3.1x
OpenEdge 10.0A
WebSpeed agents connect to database via shared memory
Each time a user clicks on a web hyperlink, the agent connects to the appropriate db for that user and then disconnects resulting in many connect/disconnect to the database

CAUSE:

Bug# OE00100271, OE00107824

CAUSE:

There is semaphore leak and thread leak in the database reconnect code via shared memory

FIX:

Upgrade to Progress 10.0B or
If upgrade is not an option, do not connect and disconnect the self service clients many times, instead, connect to database only once.