Consultor Eletrônico



Kbase P45120: Instances in Progress Explorer get lost when using multi Progress versions
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   5/8/2008
Status: Verified

FACT(s) (Environment):

Progress 9.1X
OpenEdge 10.0X
OpenEdge 10.1X
Windows 2003
Windows NT 32 Intel/Windows 2000

SYMPTOM(s):

Progress Explorer not retaining servers

Instances in Progress Explorer get lost when using multiple Progress versions on the same machine

CAUSE:

Bug# OE00088097

CAUSE:

10.X is wiping out 9.1X's proexp12.msc file and vice versa

FIX:

In order to fix the issue, please follow steps above:

1) Progress 9.1D

- go to %DLC% directory
- copy proexp12.msc to proexp_91d.msc
- backup proexp.prm file

- edit proexp.prm and remove the lines:
@{Startup\DLC}\bin\runproexp.exe
@{Startup\DLC}

add the lines:
mmc
/s
<full-directory-path-to-91d-dlc-dir>/proexp_91d.msc

2) OpenEdge 10.X

- go to %DLC% directory
- copy proexp12.msc to proexp_100x.msc
- backup proexp.prm file

- edit proexp.prm and remove the lines:
@{Startup\DLC}\bin\runproexp.exe
@{Startup\DLC}

add the lines:
mmc
/s
<full-directory-path-to-OE10.X-dlc-dir>/proexp_100x.msc

3) Now both Progress Explorers (9.1D/10.X) will retain servers