Kbase P9979: The database is stopping on a regularly basis (6092) (3712)
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  11/11/2008 |
|
Status: Verified
SYMPTOM(s):
The database is stopping on a regularly basis (6092) (3712)
bkioWrite:Unknown O/S error during write, errno 112, fd 416, len 4096, offset 1601536, file . (6092)
Filename missing from (6092) error message
SYSTEM ERROR: mtlatch 26, holding 0x4200. (3712)
Connection failure for service <service_name> host <host_name> transport <transport_name>. (5483)
bkwrite: write to disk failed errno 0. (3645)
no third-party utilities running at the time
FACT(s) (Environment):
All Supported Operating Systems
Progress/OpenEdge Product Family
CAUSE:
Connection failure because disc space is not available to grow/load the files.
errno 112: ERROR_DISK_FULL
There is not enough space on the disk.
This could be because the client temp files (srt*, lbi*, lbl*, dbl*) grew HUGE, which leads to the crash and then after the crash, the space that was allocated for the temporary files has been freed - as these files are deleted at the end of the PROGRESS session. It can also result due to full disk volumes, memory or filesystems going offline.
FIX:
Please check the environment memory, disc space mount points and consider setting -T locally on each client.