Kbase P9753: Error 1432 with 'errno 0' and -S specified with Service Name: First things to look at
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  26/10/2009 |
|
Status: Verified
SYMPTOM(s):
Trying to connect from a client to a database server.
** Could not connect to server for database <DATABASE>, errno <ERRNO>. (1432)
** Could not connect to server for database <DATABASE>, errno 0. (1432)
The service name is specified with the -S parameter in the connection string.
FACT(s) (Environment):
Progress 9.x
OpenEdge 10.x
All Supported Operating Systems
CAUSE:
The client did not find the database process listening on the port and at the IP address where the server is supposed to be.
This issue is caused by trivial TCP/IP configuration issues, such as the service name resolves to a different port number in the services file on the client and server machine.
FIX:
In order to make sure that these TCP/IP configuration issues are not the cause, starting with Progress 9.X the IP address can be specified in the "-H" parameter and the port number in the "-S" parameter. The following syntax is therefore legal:
On the host (with IP address, say, 192.10.14.2):
proserve <dbname> -S 5678 -N TCP ....
On the client:
pro <dbname> -H 192.10.14.2 -S 5678 -N TCP ...
If, after these changes, the problem goes away, check the services files on the client and server machine to ensure that the service name specified with the "-S" parameter maps to the same port number on all machines.
If, after these changes, the problem persists, please look into the other Solutions related to error 1432.