Kbase P8883: Error 1114 upon clicking the test connect button in the ODBC Administrator window
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  15/10/2008 |
|
Status: Verified
FACT(s) (Environment):
Progress 9.x
SYMPTOM(s):
Error 1114 upon clicking the test connect button in the ODBC Administrator window
Specified driver could not be loaded due to system error 1114 (MERANT 3.60 32-BIT Progress SQL92 v9.1x)
The DSN worked before installing some new software not related to progress
CHANGE:
Installed new software not related to Progress
CAUSE:
Installation of the new product caused the problem but the original problem of why the driver wouldn't load is unknown.
It could be the new software installation overwrites PATH environment so %dlc%\bin is no longer in it.
On windows the system32 directory is ususally in PATH environment variable. When there needs to load a .dll file, the Windows OS searches PATH environment variables for that dll.
FIX:
Copy the associated driver .dll (PGPRO915.DLL) from %DLC%\bin to the C:\WINNT\system32 directory, and restart the computer.