Kbase P8119: Loss of data from the MFG/Pro database for apparently no reason.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  15/10/2008 |
|
Status: Verified
FACT(s) (Environment):
Progress 9.1B
Progress 8.3D
SYMPTOM(s):
MFG/Pro 7.4
The records seem to be inserted into the database without any errors.
Confirmation that the transaction has been successfully completed is made by accessing the 3.2 and the 3.21.1 MFG/Pro Menus.
After approximately 10 minutes, the user goes back into those screens for consulting the entered data and the records seem to get lost.
The PO Receiving MFG/Pro module is the one that exhibits this issue.
Some of the MFG/Pro db tables that present loss of data are as follows: wo_master, ld_det, tr_hist, prh_hist and glt_det.
When the information disappears, the next voucher number is restored as it was before PO Receiving occurs.
The next receipt of notification number from NRM is restored as it was before PO Receiving.
PO quantity received is restored to zero again.
Inventory is restored as well.
The transaction number from the transaction history table is lost.
The voucher number and the receipt of notification number will be reused by another document.
The system informed that the address code was not found when trying to create a PO.
Turn off timeout minutes option on MFG/PRO Menu 36.3.24.
CAUSE:
This is related to the use of maintenance screens on user function keys.
FIX:
Make sure the user is properly using function keys when navigating between MFG/Pro maintenance screens.