Kbase P8034: Clients receive error Unable to attach to shared memory after someone tries to start a server for a
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  2/4/2005 |
|
Status: Unverified
FACT(s) (Environment):
HP-UX
Progress 9.1C
SYMPTOM(s):
There is no server for database <dbname>. (1423)
SYSTEM ERROR: Can't attach shared memory with segment_id <x> for <dbname>
CAUSE:
You are using procopy to make a copy of your database.
You have not updated the imprinted location information for the copy using prostrct with the repair option.
The original database is running in multi-user mode.
You attempt to start a server for the copy of the database.
FIX:
1) Shutdown the original database.
2) Modify the .st file for the copied database and re-imprint its new location into its .db file using the prostrct utility with the repair option.
<example>
prostrct repair mycopy mycopy.st
3) Restart the server for the original database.