Consultor Eletrônico



Kbase P8032: Error 44 with "db:0" due to corrupted .db file
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   14/08/2009
Status: Verified

SYMPTOM(s):

Self serve users cannot log in to the database.

Client Server Users log in with out a problem

** Database has the wrong version number. (db: <value>, pro: <value>). (44)

** Database has the wrong version number. (db: <0>, pro: <91>). (44)

FACT(s) (Environment):

All Supported Operating Systems
Progress 9.x
OpenEdge 10.x

CAUSE:

.db file for the database is corrupt.

FIX:

Rebuild the database.db file.

1. Backup the Database using OS command.
2. Rename the current db-name.db file to something like db-name.db.old
3. Verify the db-name.st file is up to date and lists all extents of the database.
4. Run the following command:
prostrct builddb <dbname> <db-name.st> to create a new .db file.

Revert to most current backup is this fails.