Kbase P7768: Database Crash - Unable to extend database within area . (8897)
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  08/03/2010 |
|
Status: Verified
SYMPTOM(s):
Database crashes with error 8897
SYSTEM ERROR: Unable to extend database within area <pareaName>. (8897)
Database can be restarted and crash recovery can take place.
Errors referring to a data extent while attempting to update database.
SYSTEM ERROR: Attempted to exceed 2GB limit with file <pname>. (8898)
SYSTEM ERROR: Attempted to exceed maximum size on file <pname>. (9452)
Database shuts down abnormally again.
FACT(s) (Environment):
All Supported Operating Systems
Progress/OpenEdge Product Family
CAUSE:
This situation arises when the database Storage Area is either:
a.) composed entirely of fixed-length extents and the last extent has become filled up,
b.) a variable length extent needs to exceed the 2Gig file size limit to accommodate writes and LargeFiles have not been enabled, or
c.) when the user hits their ulimit as defined in their .profile (UNIX) or disk quota limit (Windows)
In any of the above cases, the PROGRESS run is aborted and recovery must be run.
FIX:
Recovery of this situation requires either:
A.) Allow the database to extend more than it is currently allowed by OS limits, in which case these limits need review.
- OR -
B.) Allow the database to extend more than it is currently defined by.
1.) Ensure there is a valid backup of the Progress database
2.) Verify where there are available space on the file system
3.) Use the prostrct utility to add additional extents for the area referred in the 8898, 8897 or 9452 error message:
$ prostrct add dbname add.st
- Alternatively, consider enabling LargeFiles against the database if the Progress Version and the Operating System supports this.